Discusión:Blender 3D: novato a profesional/La Interfaz de Blender

De Wikilibros, la colección de libros de texto de contenido libre.
Ir a la navegación Ir a la búsqueda

traducción del texto original en inglés (Jhadaro)

falta por terminar, cuando lo haga, corregiré formato, ortografia (de ser necesario) y actualizo en la sección correspondiente,

Página siguiente:Aprendiendo el Sistema de Ventanas de Blender
Página anterior:Sintaxis del tutorial


Siga y abra el Blender si no lo ha hecho ya. Verá que el programa ocupa la pantalla entenra, y puede oscurecer la barra de tareas (taskbar). Los usuarios de Windows pueden presionar ALT+TAB o ALT+ESC y los usuarios de Apple pueden usar CMD+TAB o usar "Exposé" para regresar a su navegador de internet para ver esta guia. Además, en Linux puedes ejecutar el programa con la opción "-w" para que sea ejecutado en una ventana.

La pantalla principal del Blener estpa dividida en dos secciones (realmente son tres pero hablaremos de eso luego). La sección más grande (en el centro con las cuadrículas) es el "viewport" (punto de vista), la sección al fondo, mostrando una serie de controles y botones, es la ventana de botones "Buttons Windows".

Al Contrario de muchos programas, Blender dibuja y administra su propia interface ""(UI)"" , botones ventanas, menús, "Listboxes", cuadros de dialogo, etc.) en vez de usar los menús comunes de los programas basados en windows. de hecho, todos los elementos de la interface de usuario de Blender están "rendenderizados" en OpenGL. tal como los objetos 3D de una escena lo están. La Interface e Blenders se muestra y comporta de una forma un poco diferente a la forma en que una interface "normal" lo hace, y puede a veces ser confusa para los usuarios nuevos. Sin Embargo, pronto descubrirás que la interface fue diseñada intencionalmente para hacer el flujo de trabajo mucho más rápido y consistente. (Por ejemplo, puedes acercar/alejar y hacer "paneo" alrededor de una escena 3D). Otra ventaja de la interface personalizada de Blender es que es mucho más portatil, liviana y consistente a lo largo de las plataformas en la que puede ser ejecutado (windows, linux, etc.)


El 3D Viewport (Punto de Vista 3D)[editar]

La division principal es la ventana del "viewport". permite ver y manipular los objetos 3D en tu escena. las líneas de la cuadricula representan una unidad blender (BU). ¿Qupe tan grande es una BU? ¡puede ser tan grande como tu quieras! una BU puede ser de una pulgada, un centimetro, una milla. Un BU te deja decidir la escala.


La Ventana 3D Viewport

Redimensionar el Tamaño de la Ventana[editar]

Mantén tu mouse por encima del borde entre las dos ventanas (en este caso la vista 3D y la ventana de los botones "buttons windows"), el puntero del mouse cambiará a unas flechas arriba/abajo (o una mano en Mac OS X). Click the LMB (left mouse button) y arrastra. Esto redimensionará la ventana, cambiar el tamaño de la ventana de botones "button windows" causará que el tamaño del texto quede fuera de proporción con el tamaño de la ventana, para arreglar esto presiona el RMB (Right Mouse Button) y selecciona horizontal, lo cual deberia hacer el tamaño del texto acorde con el tamaño de la ventana


Blender3D windows border.png


Nota, cuando modifiques bordes en Blender nos estamos refiriendo a las lineas negras que subdividen dentro de la ventana principal de Blender; si presionas Click afuera del borde de la ventana, no estás haciendo lo que tutorial propne. También tome nota que si arrastra el borde al tope del punto de vista 3d "3d viewport" (la linea negra separando el "viewport" de la barra de menús, se dara cuenta que lo que antes se veia como una barra de menús es actualmente es la porción inferior de otra ventana llamada preferencias del Usuario "User Preferences".

Presionando CTRL+UP o CTRL+ABAJO cambia el estado maximizado de la ventana actual (en Blender3D la ventana acutal es en la cual el mouse se encuentra); repite para restablecer la ventana a su tamaño original.

User Preferences[editar]

the User Preferences window

The third division, User Preferences, is partly hidden, because most of the time you won't need all of its contents. Only its bottom-most portion is visible and looks like the normal "menubar" such as you might expect to find at the top of an application like OpenOffice. To access the hidden portion, move the black border line under the File menu down (as above--move your mouse to the top of the 3D Viewport until you see the mouse pointer change to the familiar up/down arrows. Then simply click LMB and drag down while holding). You will see many Blender configuration options hidden there. Each set of configuration options is grouped in an appropriate category, such as "View & Controls", "Edit Methods", or "Auto Save", etc., displayed as a horizontal row of buttons along the bottom. Clicking each of the category buttons displays its associated settings in the area immediately above.

For example, if you click the "Auto Save" category button, the settings associated with the automatic saving of files are displayed. I like to set "Save Versions" to "32," which preserves up to 32 older versions of the file I am working on. When a file is saved, rather than overwriting the previously written version, it is renamed "name.blend1". By preserving multiple versions of the file, I can see how my project has developed and even revert to certain older versions in case of a bad decision.

To make the current settings the default for blender:

  • 1. Open a new blender window from scratch.
  • 2. Drag the menu into view.
  • 3. Change any settings you may want to change.
  • 4. Re-hide the bar.
  • 5. Hit CTRL + UKEY.

RESETTING YOUR PREFERENCES: Your personal blender defaults are stored in the file .B.blend and a backup is stored in the .blender folder. These can be found in your home directory or "~" under Unix, and "C:\Documents and Settings\USERNAME" under Windows. To reset your defaults, simply delete the .B.blend file. It is an invisible file, so you might have to do it from the command line, or set your OS to show hidden files (In folder, option at top of window, click Tools>>Folder Options>>View and select show hidden files in the dropdown menu).

Joining and Splitting Windows[editar]

Go to the border between the 3D Viewport and the Buttons Window (note that the mouse cursor changes as before). Click the RMB or MMB. A menu will come up with the options "Join" and "Split Area". Choose Split and a bar will appear in the current window. Move the mouse cursor to the position where you want the new border and LMB to accept the change, MMB to change splitting direction, or RMB to cancel. This is especially useful in the 3D viewport. You can split it into any number of smaller viewports. Each one can be configured to show a unique view of your scene.

Now try "Join Area". Note that this has to be done on the newly created dividing line between the sections you wish to join. Select one side (the arrow shows which side will take over by darkening out the side which will be taken over). Your partitions will become one window again.

Try splitting at the right (or left) edge of the Blender window—horizontal splits can be useful.

3 Button Mice for Mac OS X Users: While Mac OS X natively uses the "Control" key to emulate the RMB, recent Blender versions for Mac OS X use the "Command" key for RMB, and the "Option" key for MMB. This behavior is also noted in the "OSX Tips" file that comes with the Mac version. If you're using a two key laptop pad, hold down both buttons at once to imitate the middle button.

While a standard 3-Button USB mouse will work with OS X, Apple sells a product called Mighty Mouse which provides three buttons, a squeeze, and a built in trackball. Using Apple's System Preferences, the middle button (the trackball) can be mapped to 'Button 3' when depressed. If you are using a much earlier version of OS X, the shareware product SteerMouse will allow you to set the scroll wheel to the Middle Mouse Button (MMB).

Window Headers[editar]

Each of the windows we have discussed so far has a "header" that can optionally be displayed at the top or bottom of its window, or hidden altogether. The header area of the 3D Viewport, for example, shows the "View", "Select", and "Object" menus, as well as a variety of buttons and other controls. RMB in the header area, and a popup menu will appear, allowing you to change the location where the header is drawn, or whether it is drawn at all. As we have discussed, when Blender first starts up (using its default interface layout), the Blender screen is divided into 3 separate sections/windows: the 3D Viewport, User Preferences, and the Buttons Window. The topmost is the "User Preferences" window with its header (showing the "File" menu, among other controls) at the bottom but the bulk of its area "off screen" above the header. The 3D Viewport also has its header shown at the bottom. The Buttons Window, on the other hand, has its header at the top of its area, so that it is adjacent to that of the 3D Viewport.

If you turn off a header and later wish to make it reappear, RMB on the edge of the window in question and select "Add Header".

It is common for an edge to be shared by two windows. To select a specific window on which to operate you bring your mouse from within the window in question to its edge. Depending on which window your mouse was in previously will determine to which you will display the menu. To accomplish this, first move the cursor to the one that is to be operated on. No button need be pressed at this time. Next move the cursor to the edge of the window and press the RMB to select the operation. Be careful not to allow the cursor to enter too far into the adjacent window. If you need to cancel the operation, press ESC.

Changing/Selecting Window Types[editar]

Each of the screen sections/windows within Blender (including those you introduce by "splitting") may be individually changed to display a desired view of your scene, or a particular set of controls. In this way, you can configure the layout of the interface in the way that is most appropriate and convenient to the task at hand. The "window type" is selectable using the icon in the leftmost corner of the window header. For example, select the icon (LMB) in the upper left corner of the Buttons Window (i.e., the leftmost end of Buttons Window header) and note the "Window Type" popup menu which appears. Select "3D View" from the menu and observe how the Buttons Window is replaced by another 3D Viewport. Reselect the Window Type button and change the window type back to "Buttons Window."



Página anterior:Sintaxis del tutorial