OpenOffice.org/Calc: la hoja de cálculo

De Wikilibros, la colección de libros de texto de contenido libre.
Saltar a: navegación, buscar

Calc: la hoja de cálculo[editar]

Primeros pasos[editar]

NB: Sobre las instrucciones y gráficos

Una hoja de cálculo es una tabla donde cada celda puede contener alguno de los siguientes tipos de datos:

  • Texto
  • Valores numéricos
  • Fórmulas

Texto es toda secuencia de caracteres que no es ni un número ni una fórmula. Para introducir un número o una fórmula como texto (p.e. un número de teléfono) hay que poner un apóstrofo al principio.

Una fórmula es una expresión que empieza con el signo = y contiene operadores, funciones, valores literales numéricos o textuales o referencias a otras celdas. Para hacer referencia a una celda hay que identificarla por la letra de la columna y el número de la fila, p.e. C2 hace referencia a la celda que está en la intersección de la tercera columna y la segunda fila. Para hacer referencia a todas las celdas de un área rectangular, se indican la primera y la última celdas separadas por dos puntos, p.e. B2:C6.

Son ejemplos de fórmulas:

Fórmula Notas
=B5 Traslada a la celda donde se encuentre los datos o el resultado de la fórmula de la celda B5
=A1+A2-A3 Suma los valores numéricos de las celdas A1 y A2 y resta el valor numérico de la celda A3
=(2*B3)/B4 El asterisco es el operador de multiplicación y la barra inclinada el operador de división
=SUMA(D5:D10) Suma los valores numéricos de todas las celdas desde D5 a D10, ambas inclusive

SUMA es una función. Para conocer todas las funciones disponibles consulta el tema de ayuda Lista de categorías y funciones en la página inicial de ayuda. También puedes usar el piloto automático de fórmulas para seleccionarlas (menú Insertar->Función).

Para que te hagas una idea práctica de cómo funciona una hoja de cálculo:

1. Descarga el documento cuentas-dpto.sxc y guárdalo en tu carpeta personal.
2. Ábrelo. Verás que se trata de las cuentas de un Departamento de Lengua Inglesa ficticio correspondientes al año 2003.
3. Introduce las fórmulas para el cálculo del saldo:
1. En la celda E5 escribe la fórmula =C5+D5.
2. En la celda E6 escribe la fórmula =E5+C6-D6.
3. Selecciona las celdas E6:E11 y ejecuta Editar->Rellenar->Abajo: la fórmula de la celda E6 se copia en las celdas inferiores ajustándose las referencias de las celdas.
4. Por último, formatea las celdas de las columnas C, D y E con formato de moneda:
1. Pulsa sobre el encabezamiento de la columna C y arrastra el puntero del ratón hasta la columna E.
2. Selecciona Formato->Celda para abrir el cuadro de diálogo Formateado de celdas.
3. En la ficha Números selecciona Categoría Moneda y pulsa Aceptar.

=== Referencias relativas y absolutas

En la hoja anterior pudiste comprobar que las referencias a las celdas se ajustaban al copiar las fórmulas: este tipo de referencias se llaman referencias relativas, y son las más corrientes. Sin embargo, en ocasiones nos interesa usar referencias absolutas, es decir, referencias que no se ajustan al copiar una fórmula de una celda a otra: para ello, ponemos el carácter $ delante de la referencia a la columna, a la fila, o a ambas, según nos interese mantener fija la referencia a la columna, a la fila, o tanto a la columna como a la fila. Por ejemplo:

Referencia relativa B2 Referencia absoluta a la columna $B2 Referencia absoluta a la fila B$2 Referencia absoluta (a la columna y la fila) $B$2

En el ejercicio siguiente podrás comprobar la utilidad de las referencias absolutas:

1. Descarga el documento calificaciones.sxc y guárdalo en tu carpeta personal.
2. Ábrelo. Verás que se trata de una hoja que calcula la nota final correspondiente a un período académico en función de un máximo de cinco notas parciales y del peso que se asigna a cada una.
3. Completa y formatea las celdas que definen el peso de cada nota:
1. En la celda I7 hay que sumar el peso de las calificaciones parciales para comprobar que es igual a 1 (100%): introduce la fórmula =SUMA(D7:H7).
2. Selecciona las celdas D7:I7, ejecuta Formato->Celda y en la ficha Números del cuadro Formateado de celdas aplica Categoría Porcentaje Decimales 0.
4. Completa las celdas de la calificación final:
1. En la celda I9 introduce la fórmula =D$7*D9 + E$7*E9+F$7*F9+G$7*G9+H$7*H9. Las referencias al peso de cada nota deben tener la fila absoluta para que sigan siendo correctas al copiarlas en las celdas inferiores.
2. Copia la fórmula en las celdas inferiores. El método más cómodo y rápido consiste en poner el puntero del ratón en la esquina inferior derecha de la celda y, cuando se transforme en una cruz, pulsar el botón izquierdo y arrastrar el puntero hacia abajo delimitando el área de relleno.
5. Por último completa la estadística:
1. En la celda D44 introduce la fórmula =CONTAR.SI(D9:D43;">=5") para contar los aprobados.
2. En la celda D45 introduce la fórmula =CONTAR.SI(D9:D43;">=5") / CONTAR(D9:D43) para calcular el porcentaje de aprobados.
3. En la celda D46 introduce la fórmula =PROMEDIO(D9:D43) para calcular la media aritmética.
4. En la celda D47 introduce la fórmula =DESVEST(D9:D43) para calcular la desviación típica.
5. Selecciona las celdas D44:D47, pon el puntero del ratón en la esquina inferior derecha de la selección y cuando se transforme en una cruz, pulsa el botón izquierdo del ratón y arrástralo horizontalmente hasta la columna I.

Las funciones de la hoja de calculo[editar]

Las funciones son instrucciones o comandos que se utilizan para que la hoja realice operaciones especificas como por ejemplo las funciones que se mostraron en los ejemplos antes mencionados del item anterior.

Estas funciones se encuentran agrupadas por tipos como podemos ver en la descripción siguiente:

  • Base de Datos
  • Fecha/Hora
  • Finanzas
  • Información
  • Lógico
  • Matemáticas
  • Matriz
  • Estadísticas
  • Hoja de Calculo
  • Texto
  • Add

Funciones de Base de Datos[editar]

en si la relacion que se tiene de la hoja de calculo es para tomar encuenta las operaciones de entrada y salida de dinero o mercancias en el caso de una empresa o algo muy usado es para la lista de asistencia escolar espero les aya ayudado este dato saludos de su cuate fercho Las funciones de base de datos son las siguientes:

  • BDCONTAR(Base de datos; Campo de Base de Datos; Criterios)
Cuenta dentro de la base de datos, todas las celdas cuyos contenidos coinciden con los valores buscados.
  • BDSUMA(Base de datos; Campo de Base de Datos; Criterios)
suma todas las celdas de un área de datos cuyos contenidos coinciden con los criterios