Zend Framework/Apéndice

De Wikilibros, la colección de libros de texto de contenido libre.
Ir a la navegación Ir a la búsqueda

Requisitos del Sistema[editar]

PHP Versión Requerida[editar]

ZF requiere PHP 5.1.4 o superior. Algunas interfaces SPL tales como Countable no eran estables en versiones anteriores de PHP. ZF tiene una colección extensa de pruebas automatizadas, que usted puede correr con PHPUnit 3.0 o superior. Esta versión de PHPUnit también requiere PHP 5.1.4 o más adelante. Aunque ZF funcionará correctamente con la versión de PHP mencionada arriba, se recomienda fuertemente utilizar PHP 5.2.3 o superior. Hay mejoras importantes de seguridad y de funcionamiento disponibles en las nuevas versiones de PHP.


Extensiones de PHP[editar]

Debajo está una tabla que enumera todas las extensiones encontradas típicamente en PHP, y cómo son utilizadas en el ZF. Esto puede ayudarle a conocer cuáles extensiones requiere su aplicación. No todas las extensiones usadas por ZF son requeridas por todas las aplicaciones. Un uso típico de "Dependencia" significa que los componentes o las clases no están habilitadas si la extensión respectiva no está habilitada. Un uso típico de "Opcional" significa que si la extensión no está habilitada, los componentes o las clases caen automáticamente usar código alternativo.

Componentes de ZF[editar]

Debajo está una tabla que enumera todos los componentes disponibles del ZF y que extensión de PHP necesita. Esto puede ayudarle a conocer cuáles extensiones requiere su aplicación. No todas las extensiones usadas por ZF son requeridas por todas las aplicaciones.

Componentes de ZF y las extensiones de PHP que usan.