OpenOffice.org/Math: el editor de fórmulas

De Wikilibros, la colección de libros de texto de contenido libre.
Saltar a: navegación, buscar

Math: el editor de formulas[editar]

Ejercicio 1[editar]

NB: Sobre las instrucciones y gráficos

Trabajar con fórmulas en el procesador de textos[editar]

OpenOffice.org Math se puede invocar desde el menú de inicio del escritorio como programa independiente, pero lo más habitual es usarlo para insertar fórmulas en un texto de OpenOffice.org Writer.

  • Para insertar una fórmula de OpenOffice.org Math en un documento de texto, pon el cursor donde quieras insertar la fórmula y selecciona Insertar->Objeto->Fórmula.
  • Para modificar una fórmula existente haz doble-clic sobre ella.

Las fórmulas, y los objetos en general, usan el mismo sistema de anclaje y posicionamiento que las imágenes, pero a diferencia de ellas, las fórmulas nuevas se posicionan de modo predeterminado como caracteres, es decir, ocupando una posición determinada en la sucesión ordenada de caracteres del documento.

Interfaz de Math: la ventana de selección y la ventana de comandos[editar]

La interfaz de OpenOffice.org Math debe presentar un aspecto similar al de la siguiente ilustración:

OpenOffice.org2 Math, Tema KDE

Selecciona Ver->Selección para visualizar/ocultar la ventana de selección. Esta ventana está dividida en dos zonas por medio de una barra horizontal: los símbolos de arriba seleccionan los grupos de símbolos que se muestran debajo; los símbolos de abajo insertan elementos de la fórmula.

La ventana de comandos permite introducir directamente los comandos o instrucciones usados por OpenOffice.org Math para representar las fórmulas. También va reflejando los comandos correspondientes a las acciones del usuario sobre la ventana de selección.

Crear fórmulas en la ventana de selección[editar]

Para crear una fórmula en la ventana de selección, debemos imaginárnosla como una estructura jerárquica y dar los pasos necesarios en orden descendente. Por ejemplo, para crear la fórmula de la ilustración previa


debemos representárnosla mentalmente así:


Luego, en la ventana de selección procederíamos del modo siguiente, respetando siempre el orden jerárquico en cada rama:

1. Crear una igualdad con dos términos.
2. Cambiar el término izquierdo por una fracción.
3. Poner unos paréntesis de agrupamiento alrededor del numerador para que los dos sumandos del paso siguiente queden en su sitio.
4. Cambiar el numerador por una suma de dos sumandos.
5. Cambiar el primer sumando por una base con exponente.
6. Cambiar el segundo término de la igualdad por una resta.

Tras las acciones anteriores la estructura de la fórmula queda completa y se muestra así:


Para terminar, sólo resta seleccionar sucesivamente cada comodín y teclear el valor o expresión que deba reemplazarlo.

Suma, multiplicación, fracciones y agrupamiento[editar]

El Ejercicio 1 consiste en escribir esta suma de fracciones:


1. Crea un documento de texto nuevo de OpenOffice.org y guárdalo en tu carpeta personal como math-01.sxw.
2. Sitúa el cursor donde quieras insertar la fórmula y selecciona Insertar->Objeto->Fórmula para abrir OpenOffice.org Math y escribir la fórmula.
3. Para crear la estructura de la fórmula en la ventana de selección, debes empezar por lo más general e ir perfilando poco a poco los detalles:
1. La fórmula es una igualdad doble, por tanto en el grupo Relaciones pulsa dos veces sobre el símbolo Es igual. En el documento se empezará a escribir la fórmula, y en la ventana de comandos irá apareciendo la codificación de la fórmula en el lenguaje de OpenOffice.org Math. Después de este primer paso, aparecerán así:
  • Documento:
  • Ventana de comandos: <?> = <?> = <?>
2. El término izquierdo de la igualdad es una suma, por tanto selecciónalo (haz doble-clic sobre el cuadradito que lo representa para que aparezca resaltado en la ventana de comandos) y en el grupo Operadores unarios/binarios aplica + de suma.
3. Cada sumando es una fracción, por tanto selecciónalos sucesivamente y aplica a cada uno el operador de fracción.
4. Ya tenemos terminada la estructura del primer término de la igualdad. Ahora selecciona cada cuadradito y teclea el número correspondiente.
5. Selecciona ahora el término medio de la igualdad y aplica el símbolo de fracción.
6. Para que las operaciones que vamos a escribir en la fracción permanezcan en su sitio, hay que aplicar los Paréntesis de agrupamiento del grupo de símbolos Paréntesis a cada comodín de la fracción.
7. Selecciona el comodín del numerador, transfórmalo en una suma, y luego cada sumando, en una multiplicación. Sustituye los comodines por los números.
8. Transforma el denominador en una multiplicación y sustituye los comodines por los números.
9. Desarrolla el tercer término de la igualdad de modo similar.
4. Una vez escrita la fórmula, haz clic sobre el documento fuera de la fórmula para volver a OpenOffice.org Writer.
5. Guarda el documento.

Ejercicio 2[editar]

Sumatorio[editar]

Prueba ahora a representar la misma fórmula con el signo de sumatorio:


1. Empieza también creando la igualdad.
2. Selecciona el segundo término de la igualdad y del grupo Operadores aplica primero el símbolo Suma y seguidamente el símbolo Límites superior e inferior.
3. Pulsa sobre el último comodín sin seleccionarlo y del grupo Formatos aplica Subíndice derecha.
4. Selecciona ahora el último comodín y aplica Superíndice derecha.
5. La estructura ya está lista: selecciona cada comodín y teclea la expresión que deba reemplazarlo.

Límites y paréntesis[editar]

Escribe ahora la definición del número e:


1. Como siempre, empieza por la igualdad.
2. Con el primer término seleccionado, pulsa e.
3. Selecciona el segundo término y del grupo Operadores aplica primero el símbolo Límites y seguidamente el símbolo Límite inferior.
4. Con el comodín pequeñito seleccionado, aplica el símbolo Tiende a del grupo Relaciones.
5. Con el primer comodín pequeñito seleccionado, pulsa n para poner n a la izquierda de la flecha.
6. Selecciona el otro comodín pequeñito y aplica el símbolo Infinito del grupo Otros.
7. Selecciona el comodín y aplica el símbolo Superíndice derecha del grupo Formatos.
8. Con el comodín grande seleccionado, aplica el símbolo Paréntesis graduables del grupo Paréntesis y luego el símbolo + de suma del grupo Operadores unarios/binarios.
9. Selecciona el segundo comodín grande y aplica el símbolo División (fracción).
10. Por último, selecciona los comodines y teclea los valores correspondientes.

Ejercicio 3[editar]

Símbolos y letras griegas[editar]

OpenOffice.org Math dispone de conjuntos ampliables y personalizables de símbolos para usar en las fórmulas. Para insertar un símbolo:

1. Pulsa el símbolo Símbolos de la barra de herramientas (o selecciona Herramientas->Catálogo) para abrir el cuadro de diálogo Símbolos.
2. Selecciona un conjunto de símbolos, luego un símbolo y pulsa Aplicar para insertarlo en la fórmula.
3. Cuando hayas insertado todos los símbolos deseados, pulsa Cerrar.

Radicales e integrales[editar]

Intenta escribir ahora la fórmula de la desviación típica:


Y la definición de π como área de un círculo de radio 1:


Ejercicio 4[editar]

Crear fórmulas en la ventana de comandos[editar]

Como habrás observado, a medida que vas seleccionando símbolos en la ventana de selección, en la ventana de comandos se va escribiendo la fórmula en el lenguaje de OpenOffice.org Math. Si necesitas escribir muchas fórmulas, te vale la pena aprender los comandos más usados y escribir la fórmula directamente en la ventana de comandos. Por ejemplo: Fórmula Comandos Notas

y = ax^2 + bx + c El símbolo ^ introduce un exponente x_1 + x_2 = 0 El guión bajo introduce un subíndice 2 over 4 = 1 over 2 El comando over crea una fracción y = {x + 1} over 2 Los corchetes se usan para agrupar sen 45º = sqrt 2 over 2 El comando sqrt crea una raíz cuadrada 2 %pi r Las letras griegas y demás símbolos se insertan con su nombre precedido del símbolo de procentaje left [ matrix{a_1^1#a_1^2 #a_1^3 ## a_2^1#a_2^2#a_2^3 ##a_3^1 #a_3^2#a_3^3} right ] Por medio de la ventana de selección sólo podemos crear matrices de dos filas por dos columnas; para añadir más filas y/o columnas tenemos que usar la ventana de comandos: un símbolo # sencillo separa columnas; dos símbolos ## separan las filas.

Para consultar todos los comandos disponibles, abre la ayuda de OpenOffice.org Math y consulta la sección Referencias.

Si no conseguiste crear las fórmulas de la desviación típica y de π, aquí las tienes. Cópialas y pégalas en la ventana de comandos de OpenOffice.org Math: Fórmula Comandos

%sigma = sqrt{1 over N sum from{i=1} to{N} (x_{i} - bar x ) ^{2}}

%pi = 2 cdot int from{-1} to{1} sqrt{1 - x^{2} } dx


Personalizar los catálogos de símbolos: formulación química[editar]

Con OpenOffice.org Math puedes escribir fórmulas químicas sencillas, si bien necesitarás personalizar los catálogos de símbolos para suplir las carencias de un programa pensado para la formulación matemática. Las fórmulas químicas más complejas pueden crearse con OpenOffice.org Draw.

En primer lugar crea los símbolos:

  1. Pulsa el símbolo Símbolos de la barra de herramientas para abrir el cuadro de diálogo Símbolos y pulsa Editar.
  2. Vamos a crear un símbolo para la reacción reversible (necesitarás tener instaladas una fuente Unicode, como la Lucida Sans Unicode o la  Arial Unicode MS):
        1. Introduce los datos siguientes: Símbolo ReacciónReversible, Conjunto de símbolos Química, Fuente Lucida Sans Unicode, Área Flechas.
        2. Selecciona el carácter Unicode correspondiente (U+21C4: ⇄) en la tabla de caracteres y pulsa Añadir.
  3. Crea también símbolos para EnlaceHorizontal y EnlaceVertical con los caracteres Unicode U+2500 (─) y U+2502 (│).
  4. Pulsa Aceptar para salir del cuadro de edición y Cerrar para salir del cuadro Símbolos.

Ahora ya puedes crear fórmulas como estas: Fórmula Comandos

nitalic { CO_2 + H_2O %ReacciónReversible H_2CO_3 }

nitalic { R_1 %EnlaceHorizontal stack { R_2 # %EnlaceVertical # C # %EnlaceVertical # R_3 } %EnlaceHorizontal OH }